E2150 - Map Creation Tutorial

From InsideEARTH
Jump to navigation Jump to search

Welcome to Map Creation Tutorial for Earth 2150. Scroll through this page and you will know how to quickly and without any effort create new map of your dreams.

What do you need

The necessary things you should already have:

  • graphic editor (Paint or Gimp etc.)
  • BMP Templates
  • Earth 2150 installed

At the beginning I suggest you to pick one of BMP templates depending on how big map you want to create. You have the choice between Huge, large, medium and small. For example for 4 players map I will take Large template.

Editing map template

I'm familiar with Gimp editor so I decide to open downloaded BMP template file in this application. First of all I set image mode to 8-bit Grayscale. Open Image tab and correct Mode and Precision like it was shown on the screenshots below.

Grayscale mode in Gimp
8-bit precision in Gimp























































Gray color selecting


You can prepare map draft by filling mentioned template with gray scale colors in 0-255 resolution. Color can be selected in a tool section (visible on the left side of the Gimp window). Just click on a coloured rectangle in order to change it. In appeared window (screen on the right) click on HSV color mode (1), select S parameter (2) and choose desired gray hue (3) then press OK. I sometimes use V parameter slider when I need very precise gray tint.

Important thing is that the closer the color is to white, the higher terrain will be. You can always invert this later in Earth 2150 Editor. So dark grays mean depressions and light tints - highlands. Using edge values (black and white) is not recommended.

As you can see on the template there is black outline of a rectangle. It indicates the limits of the possibility of moving and building around the map. Terrain outside this range will not be accessible in game, but still visible. Don't leave that outline black unless you want to have cracks on the edges of the functional map.




Gradient tool selected
Unlocking entire image for painting


If you want to create smooth transitions between altitudes I suggest using gradient tool. Just select right edge colors before. I often use Rectangle Select Tool or Fuzzy Select Tool (this magical rod) to mark the area which I want to fill with gradient or bucket of color. All these instruments are available in the tool section mentioned before. Sometimes you may be surprised that you are not able to paint in some locations of the image. That's because you have selected different working zone. You can get rid off selection by clicking in a Select tab on None option or All if you prefer.


Most of PvP arena style maps are symmetric. You can achieve that by filling only half or even quarter of the template and then selecting completed fragment and copying it with transformation. You can find flip and rotate option in Transform menu after clicking on a Layer tab in the top window bar (next to Image tab where you were choosing gray scale mode).





New window in map Editor with size selection indicated


Finished project export as BMP file and move it into Earth 2150 game main location. After entering the Map Editor click on the Menu then New and select proper map size (as used by you template) and press Create. After this you can open console with Enter keyboard button and type :

Editor.LoadBmp your_map_draft.bmp



You may want to see your work from a further perspective. Type in console code below and you should be able to zoom out enough to see entire map. But don't overdo it as your machine may not be able to take it and the game will crash.

graph.zoom.max=500


That's almost all

The only thing left now is painting your new map with textures and placing stuff like resources or trees. Remember that you can reverse your action by holding Shift keyboard key. Objects can be rotated with NUM_Enter key before you place them. If you want to delete something - hold Shift and click on it. Be ware of Undo button in Generator tab, because it resets entire map to a starting stage - sets it as totally flat. It might ruin your efforts so I suggest opening again a saved map file (if you saved it before) or reloading BMP file. It's good that textures and objects remain even if you load different draft. Just mind to open game Menu and set its properties then save after you end playing with a map.


Thank you for reading. I hope it helped you a bit. And good luck in creating your own creative maps. Don't be reluctant with publishing your creations on a community forum.